Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Bad http status code

  1. #1
    Join Date
    Oct 2010
    Posts
    25

    Default Bad http status code

    This msg came up this morning on scanning (or searching for) some new disks.
    Anyone?
    Thanks!

  2. #2
    Join Date
    Feb 2009
    Posts
    1,548

    Default

    Quote Originally Posted by barend View Post
    This msg came up this morning on scanning (or searching for) some new disks.
    Anyone?
    Thanks!
    Can you post a complete session log from other tab of the error message box? It's hard to tell without looking at session log.

    Andrei

  3. #3

    Default

    I received a similar message today. Here is the session log from the other tab:

    Connecting to api.discogs.com
    >| GET /database/search?artist=dylan&oauth_consumer_key=DZqYcaUCZBr eeEHlYxXY&oauth_nonce=QYo4Xiro2PamAGFAddLoS6s&oaut h_signature_method=HMAC-SHA1&oauth_timestamp=1414270474&oauth_token=dXMoXl xWRZwlqGiQLhfLUPiXPWtfDqEeigNbzIlx&oauth_version=1 .0&page=1&per_page=100&type=release&oauth_signatur e=7rYrv2nom7G7CzRvXXJFWct1e2k%3D HTTP/1.1
    >| Accept-Encoding: gzip
    >| User-Agent: OrangeCD 6.4
    >| Host: api.discogs.com
    >| Connection: Keep-Alive
    >|
    <| HTTP/1.1 401 Unauthorized
    <| Reproxy-Status: yes
    <| Access-Control-Allow-Origin: *
    <| Cache-Control: public, must-revalidate
    <| Content-Type: application/json
    <| WWW-Authenticate: OAuth realm="http://api.discogs.com"
    <| Content-Length: 61
    <| Connection: close
    <| Date: Sat, 25 Oct 2014 20:54:45 GMT
    <| Server: lighttpd
    <|
    <| {"message": "You must authenticate to access this resource."}

    For background, I had to restore my PC recently due to a power outage, so I reinstalled my Orange software today and tried to load music into my database, and received the errors noted above.

    Any help will be greatly appreciated.

    John

  4. #4
    Join Date
    Oct 2005
    Location
    Malta
    Posts
    258

    Default

    Your version of OrangeCD is 6.4.
    Try updating to new 6.5
    Maybe it will solve the problem

  5. #5
    Join Date
    Mar 2009
    Posts
    27

    Default

    I get this, too

    I am using 6.5.4. I see the album in the freedb results, but clicking Preview and Add results in the error message and this session log

    Connecting to freedb.mygenres.com
    >| GET /freedb/jazz/7e0c030a HTTP/1.1
    >| User-Agent: OrangeCD 6.5
    >| Host: freedb.mygenres.com
    >| Connection: Keep-Alive
    >|
    <| HTTP/1.1 404 Not Found
    <| Date: Sat, 15 Nov 2014 21:07:03 GMT
    <| Server: Apache/2.2.3 (CentOS)
    <| Content-Length: 302
    <| Connection: close
    <| Content-Type: text/html; charset=iso-8859-1
    <|
    <| <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <| <html><head>
    <| <title>404 Not Found</title>
    <| </head><body>
    <| <h1>Not Found</h1>
    <| <p>The requested URL /freedb/jazz/7e0c030a was not found on this server.</p>
    <| <hr>
    <| <address>Apache/2.2.3 (CentOS) Server at freedb.mygenres.com Port 80</address>
    <| </body></html>

    I would like to change from freedb.mygenres.com to freedb.freedb.com but when I do this in Preferences the change is saved but this session log suggests it did not take effect. I wonder if that is the issue.

  6. #6
    Join Date
    Oct 2006
    Location
    Posts
    289

    Default

    In the CD info download URL specification box leave out one of the freedb's and see what happens. I use http://freedb.org/~cddb/cddb.cgi and it works just fine.

  7. #7
    Join Date
    Mar 2009
    Posts
    27

    Default

    Quote Originally Posted by Jazz_North View Post
    In the CD info download URL specification box leave out one of the freedb's and see what happens. I use http://freedb.org/~cddb/cddb.cgi and it works just fine.
    Thank you for the suggestion, however that did not change my session details:

    Connecting to freedb.mygenres.com
    >| GET /freedb/jazz/7e0c030a HTTP/1.1
    >| User-Agent: OrangeCD 6.5
    >| Host: freedb.mygenres.com
    >| Connection: Keep-Alive
    >|
    <| HTTP/1.1 404 Not Found
    <| Date: Sun, 16 Nov 2014 01:18:05 GMT
    <| Server: Apache/2.2.3 (CentOS)
    <| Content-Length: 302
    <| Connection: close
    <| Content-Type: text/html; charset=iso-8859-1
    <|
    <| <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <| <html><head>
    <| <title>404 Not Found</title>
    <| </head><body>
    <| <h1>Not Found</h1>
    <| <p>The requested URL /freedb/jazz/7e0c030a was not found on this server.</p>
    <| <hr>
    <| <address>Apache/2.2.3 (CentOS) Server at freedb.mygenres.com Port 80</address>
    <| </body></html>

    I set the recommended URL:
    temp.png

    and picked "Apply", but since freedb.mygenres.com still shows in the session I am under the impression that the latest version is not recognizing the set URL for me.

  8. #8
    Join Date
    Feb 2009
    Posts
    1,548

    Default

    Working on both issues today. Thanks for your patience.

    Andrei

  9. #9
    Join Date
    Oct 2006
    Location
    Posts
    289

    Default

    It's just the Apply button that doesn't work. The change works if you use OK.

  10. #10
    Join Date
    Mar 2009
    Posts
    27

    Default

    Any update on this? It is still happening for me. It may only be happening when searching FreeDB by Album Title

    I am using http://freedb.org/~cddb/cddb.cgi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •