Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Slowness Fixed [now REALLY fixed]

  1. #1

    Default Slowness Fixed [now REALLY fixed]

    Hello Everyone:

    I think I finally fixed the slowness problem. I just installed the newest build an thought it might fix the "database crawl".

    My 1500 album database was so slow I seriously thought I would drop OrangeCD as it was taking 30-120 seconds to refresh after I clicked or right-clicked anything.

    All my images are "stored externally if over 0KB". Nothing I tried worked to improve the speed and response, except one little gem.

    People turn off the "store thumbnail" setting. Bingo...now it's fast..very fast.

    Go to:
    1. View then Preferences
    2. Click Imaging
    3. De-select (no check) next to "Store Thumbnails in the Database.

    Patrick

  2. #2

    Default Re: Slowness Fixed

    Doesn't work for me. I'd already done that - OCD is the slowest program in the world

  3. #3

    Default Re: Slowness Fixed

    Just timed it:
    1 min 14 seconds for right click menu to appear.
    Latest Build
    Vista
    Fast computer
    3500 albums

  4. #4
    Join Date
    Feb 2009
    Posts
    1,548

    Default Re: Slowness Fixed

    This is ugly.

    What is the state of "Store thumbnails in the database" checkbox? Try to turn it off and compact database.

    Do you hear hard drive "churning" when this happens? Do you have enough free space on the drive? Windows tend to fragment files wildly when there is not enough space - and that can make OrangeCD slow.

    Andrei

  5. #5

    Default Re: Slowness Fixed

    Quote Originally Posted by Firetongue
    This is ugly.

    What is the state of "Store thumbnails in the database" checkbox? Try to turn it off and compact database.

    Do you hear hard drive "churning" when this happens? Do you have enough free space on the drive? Windows tend to fragment files wildly when there is not enough space - and that can make OrangeCD slow.

    Andrei
    Yes it is unchecked. And I've compacted.
    129GB of free space on my hard drive..
    ..ah, but only 4.8GB of 232GB on the external drive thst holds most of the mp3s in my database. But no churning & media monkey works fine when playing them.

  6. #6
    Join Date
    Feb 2009
    Posts
    1,548

    Default Re: Slowness Fixed

    Last thing - which build is this? There was serious performance problem in one of recent builds, but it was fixed.

    Andrei

  7. #7
    Join Date
    Oct 2005
    Location
    Malta
    Posts
    258

    Default Re: Slowness Fixed

    Andrei,

    I think that this is a problem with Vista. I too encounter slowness problems. I have a Dell Pentium D 3.2 Ghz; two 250Gb hardrives with about 180 Gb free on each disk; 2 Mb ram. The "Store thumbnails in the database" is unchecked and I have to compact database regularly to maintain reasonable performance. I am using 6.22 and have Vista SP1 installed.

    Another possible Vista problem related to OrangeCD is that the CD is not ejected automatically when the CD ends playing. It has to be ejected manually.

    Regards

    Joe





  8. #8

    Default Re: Slowness Fixed

    Quote Originally Posted by Firetongue
    Last thing - which build is this? There was serious performance problem in one of recent builds, but it was fixed.

    Andrei
    6.2.2 build 12315

  9. #9

    Default Re: Slowness Fixed

    I too am having this problem. I'm using XP and the build is 12315. It takes forever for the drop down box to do anything. I thought I fixed it when I upgraded to this build, because it came out of the box not problem at all. But today I got on and bam!! Why?

  10. #10

    Default Re: Slowness Fixed

    Andrei, you've got to help. I love this program and would probably lose control of my collection without it (i've got over 2500 cds), but I just can't believe how slow the program is running. I'm currently viewing my Beatles cds in thumbnail mode. I have 706 cds of the Beatles and it took over 12 minutes to load all the thumbnails. When I upgraded to the current build, immediately after doing so, the program worked like new. Now... like I said, I love this program but this is insane. I've done all the fixes that were recommended in preferences but still it's slow. I know I'm not the only one with this problem, but you have to fix this. Please.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •